
10:    Using Integrated Program Modeling
Integrated Program Modeling (IPM) allows you to model and compare multiple traffic management 
initiatives (TMIs), and to review their impact on other data sets. This version of IPM only provides 
modeling capabilities and does not allow you to send scenarios.
In FSM 8.70 you could model one program’s effect on multiple data sets. For example, you could 
analyze the effect of one Airspace Flow Program (AFP) on many airports. For more information, see 
Chapter 8: Impact Modeling.
As of FSM 8.80 you could model and compare multiple programs and their impact on other data 
sets. For example, you can model the effects of multiple GDPs on an FCA.
Note the following limitations:

• You cannot send programs (proposed or actual).
• You cannot alter Data Time.
• You cannot include multiple instances of an element in a scenario.
• You cannot run Blanket or Compression TMIs.
• You cannot model AFPs before airports TMIs.
• You cannot model a CTOP, it can only be used as an impact element.
• AFP exemptions within a GDP are limited to existing AFPs.
• You cannot model re-controls in a purge.
• There is no support for Historical IPM mode.

Building Scenarios
The first step in using the IPM tool is to create one or more scenarios in the Scenario Manager 
component. The creation of a scenario involves selecting the elements that are either going to be 
controlled through initiatives or may be impacted by those initiatives. In this example, GDPs are 
included in a scenario because you want to see their impact on an FCA.
To better understand the IPM Mode, review Chapter 3: Integrated Program Modeling Components 
prior to creating the scenarios.

1. From the FSM Control Panel component, click IPM Mode. The IPM Mode (Scenario Manager
and Multi Graph) opens.

2. On the Scenario Setup  tab > Available  box in the Scenario Manager component, select the
airport or airspace to be included in a scenario.

3. For the scenario that you are building, click Add Model  to add the element that you want to
model, or click Add Impact  to add the element that you want to review the impact of the
modeled elements. As you move an element into a scenario, it is displayed in the
corresponding Multi Graph tab. FSM highlights the Scenario Manager tabs with a red border to
indicate that modifications have been made in Scenario Manager.

Note:   You can add up to eight elements within each scenario. An FCA in a CTOP cannot only



be added as an impact element.

4. Repeat the previous two steps for each element. In this example, three scenarios are
compared (see Figure 10-1).

Figure 10-1: Scenario Manager with Three Scenarios Created

5. To change parameters, right-click the element in the Scenario box, and select IPM Setup  (see
Figure 10-2) or click the appropriate Scenario tab, and click the Element ID  action button to
open the IPM Setup component.



Figure 10-2: Right-Click Menu Option to Open IPM Setup

Note:   The IPM Setup (see Figure 10-3) component is very similar to GDT Setup.

Figure 10-3: IPM Setup Component

6. Select the program type from the Program Type  dropdown menu. This step is only necessary
if you want a program type other than the one defined when you created the scenario.
Note:      Compression and Blanket programs are not available in IPM.

7. On the Parameters tab of the IPM Setup panel, complete the Program Time Options section.



For this example, enter the following:
• Start Time  – 161415 (ddhhmm)
• End Time  – 162114 (ddhhmm)

8. Enter the appropriate values for the program into the Program Rate  section of the Parameters
tab.

9. Complete the Include Only Options section by selecting values for Arrival Fix, Aircraft Type,
and Carrier.

10. Click the Scope tab, and enter the appropriate values for the program. For this example,
enter the following:
• Select By  – Distance
• Scope  – 400 nm

Note:   Any changes you make to the IPM Map  are dynamically reflected in the IPM Setup
component’s Scope tab.

11. Click Scenario Mgr  to close the IPM Setup components and return to the Scenario Manager
component. Continue to change the parameters for each Model element in each scenario.

12. If you want to re-use an element in another scenario (for example, BWI and DCA are used
in Scenario 1 and Scenario 2). Select the down arrow next to the Scenario label and select
Copy to > Scenario 2  (see Figure 10-4). This copies the list of elements and all parameters
to Scenario 2.

Figure 10-4: Copy To Functionality

13. If you have been modeling a GDP for a while, you may have missed some incoming ADLs.
Before modeling the GDP parameters, you may want to update the data for your proposed
TMI. To do this, click Reload All  on the IPM Setup component. The Reload All  button is
active only when the actual data time is more recent than the data available in IPM mode.
Clicking Reload All  also models all elements in all scenarios.

14. Click Model All  to model all scenarios. Note the logic used to model the programs:
• Airports are modeled before FCA/FEAs.
• Elements are modeled in the order that they are listed.
• Impact data elements are processed after all TMIs are modeled.
• Each scenario is a separate optional operational solution, only one of which can be

implemented. Each scenario is processed independently of other scenarios.
• All scenarios are modeled.



15. Click Reset All Parameters  to clear any elements of the modeled data, and return the IPM
settings to their defaults. You cannot reset just one element. To reset just one element
without resetting the other elements, remove it and re-add it to the scenario by selecting the
element, and clicking Remove.

The previous steps reviewed changing parameters through the IPM Setup Component. An alternative
method is to click the Scenario tab in the Scenario Manager component and update the Program
Type, Program Rate, Scope, Start Time, and End Time  fields directly on the Scenario tab. (see Figure
10-5).

Figure 10-5: Changing Parameters on Scenario Tab

Using Modeled Data in a Program
If you want to run a program using the modeled parameters for an element:

1. Click the appropriate Scenario tab in Scenario Manager. From the Element Id  dropdown menu,
select Open New GDT Mode Instance  (see Figure 10-6). This opens a new instance of GDT
Mode and copies all the parameters to that GDT Mode. GDT Mode is opened with the ADL
currently opened in the Scenario Manager. If the element’s ADL for the Scenario Manager is
later than the current ADL time, click Reload All.



Figure 10-6: Open New GDT Mode Instance

2. Click Run  to send the program.
Note:      This may yield different results and metrics than your model.

Modeling Analysis

Preview Your Work
After clicking Model All or Reload All in the IPM Setup component, all IPM components are updated 
with the modeled GDPs. Viewing these components can help you determine the effect of the model 
GDPs on the impact data set. The IPM components are the same as what you view in GDT Mode. 
All of the following components are based on a BWI modeled GDP program.

IPM Multi Graph Component
The Multi Graph component provides a comparative view of the bar graphs of all the data sets in 
the scenario (see Figure 10-7). The functionality is the same as that found in GDT Mode Bar 
Graph; however, there are some menu option differences. See Chapter 3: Integrated Program 
Modeling Components for information on the menu differences.



Figure 10-7: IPM Multi Graph View

IPM Metrics Tab
The Metrics grid is accessed on the IPM Multi Graph component. It contains expandable trees to
simultaneously display consolidated statistics across all scenarios (see Figure 10-8). Use different
combinations of the Grouping and Display options to analyze the data.



Figure 10-8: IPM Metrics Tab Grouped by Resource

IPM Time Line Component
To open the IPM Time Line, select View > IPM Time Line  from the IPM Setup component. You can
preview the changes made in the Time Line as a result of running the IPM model (see Figure 10-
9). A quick glance at the Time Line shows you the distribution of flights, the number of cancelled
flights (squares), and the number of delayed flights (triangles).



Figure 10-9: IPM Time Line View

IPM Bar Graph Component
By default, the IPM Bar Graph displays both solid and hashed bars. Solid bars represent the original
data, while hashed bars represent modeled data. Uncheck View > Current Data  from the IPM Bar
Graph to view only modeled data. The modeled AAR line (dashed white line) is displayed by default
when in IPM mode. The Bar Graph can indicate if the stack at the end of the program is a
potential problem and allows you to view the overall impact of the program (see Figure 10-10).



Figure 10-10: IPM Bar Graph View With Current Data Option Unchecked

For more information on the IPM Bar Graph component, see Chapter 3: Understanding Components.

IPM Data Graph Component
The IPM Data Graph provides a visual statistical representation of the modeled GDP. The Power 
Run option that you ran is displayed on the X-axis (see Figure 10-11). Using your mouse, drag the 
black vertical line to the desired Power Run option or just click the mouse over the desired option 
to move the line. The delay statistics to the left of the Data Graph reflect the line of delineation of 
the scenario. Additionally, changing the Power Run option automatically updates all IPM components 
to reflect the new parameters. Rolling your mouse over any line in the Data Graph gives you the 
delay statistic count for the colored line that reflects the results of the option.



Figure 10-11: IPM Data Graph View

For more information on the IPM Data Graph component, see Chapter 3: Understanding 
Components.

IPM Map Component
The IPM Map component provides a visual representation of the modeled scope of the GDP (see 
Figure 10-12). The burgundy highlighted areas indicate the scope of Non-Exempt flights. Airports that 
are colored red are Non-Exempt and Airports colored green are Exempt due to the scope of the 
modeled GDP. Clicking an Airport or Center will change the scope of the GDP and simultaneously 
update the IPM Setup component.



Figure 10-12: IPM Map View

For more information on the IPM Map component, see Chapter 3: Understanding Components.

IPM Flight List Component
To open the IPM Flight List, select View > Flight List  from the IPM Setup component. The IPM
Flight List allows you to view the modeled results for multiple flights (see Figure 10-13).

Figure 10-13: IPM Flight List View

For more information on the IPM Flight List component, see Chapter 6: Viewing Flight Information.

IPM Demand By Center Component
To open the IPM Demand by Center, select View > Show Demand  from the IPM Setup component
or click Show Demand  on the Scope tab. The IPM Demand By Center component displays non-
active, non-completed, and included flights that are Non-Exempt or Exempt by the modeled GDP
(see Figure 10-14). Included flights are the combination of both Exempt and Non-Exempt flights
included in the modeled GDP. The Demand by Center component lists all Centers and the top five
airports, as defined by the number of included flights within each center for the modeled GDP. Click
the key icon to the left of the Center coloring to expand the Center selection and display the
airports. The Centers are ordered in descending order based on the number of Non-Exempt flights.
The red colored Centers indicate that there is at least one Non-Exempt flight within the Center.
Using this component can help you make decisions on the scope of your GDP based on the
number of Non-Exempt and Exempt flights.
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Figure 10-14 : Demand by Center View

For more information on the Demand by Center component, see Chapter 3: Understanding 
Components.

Understanding IPM Components



• Skip & Continue  - proceeds to the next sequential action without completing the specified action.
This is only available when the action is one in a sequence of actions.

• Cancel  - stops the entire send process and an Autosend Cancel Warning displays. FSM then
activates the Resend menu options based on the type of TMI you are trying to send.

Figure 3-95: Action Failed dialog box
Cancelling the Program Manager

You have the option to cancel the Program Manager actions at anytime. Clicking Cancel  at the
bottom of the Program Manager stops the program transmission process (including the Autosend
segments), but does not cancel sending any tasks that have already been sent or are in progress.
A warning message displays, “Canceling the Program Manager while transmitting information may
produce unexpected results. Do you still wish to cancel the Program Manager?”

Figure 3-96: Cancellation Message

If the program transmission process has been cancelled in the middle of sending certain types of 
information to the hub site, then the Send (or Purge) button is enabled and you can click
Send/Purge again. Resend is not available for cancelled programs. The Resend menu on the 
Coversheet is enabled when the GDP_PARAM—or BLKT_PARAM, etc.— (for a Proposed TMI) is 
sent successfully, when the FADT (for an Actual GS/GDP/BLKT/COMP) is sent successfully, or when 
the EDCT_COMMAND task (for Purge) is sent successfully.

Integrated Program Modeling Components
Integrated Program Modeling (IPM) allows you to model and compare multiple traffic management 
initiatives (TMIs), and to review their impact on other data sets. In the current FSM version, IPM 
provides modeling capabilities only; in other words, you cannot send TMIs.
The actual integrated program modeling of Traffic Management Initiatives (TMIs) is covered in 
Chapter 10: Using Integrated Program Modeling. This section familiarizes you with the IPM and IPM
Setup components:

• IPM Scenario Manager
• IPM Multi Graph
• IPM Setup (opened from Scenario Manager)

• IPM Map
• IPM Bar Graph



• IPM Data Graph
• IPM Demand by Center (Optional)
• IPM Time Line (Optional)
• IPM Flight List (optional)

Opening IPM Mode
From the FSM Control Panel component, use one of the following methods to open IPM Mode:

• Click IPM Mode
• Select View > IPM Mode
• Press Ctrl + I

Scenario Manager and Multi Graph are the two default components that are displayed when you
open IPM mode (see Figure 3-97). Scenario Manager and Multi Graph are interactive; any change
made in one is dynamically reflected in the other component.
The IPM Setup and IPM Map components are interactive; any change made in one is dynamically
reflected in the other component. Like GDT mode, when you model the scenarios, the other IPM
Setup components reflect the changes made to the IPM Setup and Map.

Note: All IPM components are labeled IPM in the component title bar. IPM Setup components
also include the Scenario number in the title bar.

Figure 3-97: IPM Default Components



Scenario Manager Component
The IPM feature combines FSM-implemented TMIs into one or more system-wide views, referred to
as scenarios. A scenario is a collection of data sets, program types, and parameters for modeled
and impact data sets. The scenarios allow you to compare programs’ effects on one another and to
compare multiple strategies at one time.
The first step in using the IPM tool is to create one or more scenarios in the Scenario Manager
component (see Figure 3-98). The creation of a scenario involves the selection of elements that are
either going to be controlled through initiatives or may be impacted by those initiatives. For example,
a GDP(s) may be included in a scenario because you want to see its impact on an FCA.

Figure 3-98: Scenario Manager Component After Scenarios are Created



Scenario Manager Menu Bar

The menu bar in the Scenario Manager component contains three menus: File, View, and Help.
1. File Menu

• File > Close  - Closes the Scenario Manager window.
2. View Menu

• View > IPM Multi Graph  - Opens the Multi Graph component.
• View > Rename Window  - Opens the Rename Window dialog box to change the component

name in the title bar.
3. Help Menu

• Help > Scenario Manager  - Opens the on-line help information specific to Scenario
Manager.

• Help > Scenario Manager Tab  - Opens the on-line help information specific to Scenario
Manager tabs.

Scenario Manager Panel Buttons

The following action buttons are located below the Menu bar.
• Reload All  - Loads the latest ADL data and models the data for all elements in all scenarios.

This button is enabled only if there are elements present in any of the scenarios. Note that
Reload All  is run automatically each time an element is added to a scenario.

• Model All  - Applies selected models to all elements in all scenarios. This button is enabled only
if there are elements present in any of the scenarios.

• Run Scenario  - This button is for future use and is disabled at all times.
• SUB OFF  - This button is for future use and is disabled at all times.
• Reset All Parameters  - Loads the most current ADL, clears any elements of the modeled data,

and returns the IPM settings to their defaults.
Scenario Manager Tabs

Scenario Manager consists of four tabs. The Scenario Setup tab provides a high-level view of all
scenarios and is where you create scenarios. Scenario 1, Scenario 2, and Scenario 3 provide a
detailed view of the scenarios.
Scenario Setup Tab

Available Box  - The Available box lists all available Airport and FEA/FCA elements from the FSM
server’s list of monitored live elements. The elements in the Available box are grouped by Currently
Open Data Sets, FEAs/FCAs, and Center. The number of available FEAs/FCAs and Centers are
listed in parenthesis. For example, Center (17 Airports) means there are 17 airports being monitored.
Any program information and update times associated with the element is displayed next to the
element name. FSM updates the program information and update times for each element when it
receives new information from the ADL.
Buttons  - Five buttons are displayed to the left of each Scenario box. The following buttons are
used to create the scenarios and manipulate their order within scenarios:

• > Add Model  - Adds selected elements as modeled elements to the specified scenario. Use the
Shift or Ctrl keys to select and add multiple elements. The elements will be added to the bottom
of the appropriate Airport or FEA/FCA list.



Note: FCAs included in a CTOP will not be available to add as a model, and the Add Model
button will be unavailable.

The default TMI selection will be the underlying program type; otherwise, by default, the elements
will be added as GDP-DAS or AFP-DAS.
You can add up to eight elements within each scenario. If you attempt to add more elements to a
scenario than the maximum allows, an error message reading “Maximum number of elements in
Scenario has been exceeded” is displayed.
If you select an element that cannot model a GDP (e.g., Mexican elements) an error message
reading, “[Element Name] can only be added as an Impact element” is displayed. The message also
is displayed if you multi-selected elements and at least one of them cannot be added. In such a
case, none of the selected elements will be added.

• > Add Impact  - Adds selected elements as impact elements to the specified scenario. Use the
Shift or Ctrl keys to select and add multiple elements. An impact data set is defined as a data
set for which you would like to view the effect of a modeled TMI. The added element will be
added to the bottom of the appropriate Airport or FEA/FCA list. By default, elements will be
added as Impact.

• < Remove  - Removes a selected element from a scenario. When you remove an element, you
lose any associated parameters.

• Move Up  - Moves up the position of a selected element. The order shown is the order the
elements will be modeled. The button is disabled if no element is selected or if the selected
element is in the top-most position. You cannot move the Airports and FEAs/FCAs folders.

• Move Down  - Moves down the position of a selected element. The order shown is the order the
elements will be modeled. The button is disabled if no element is selected or if the selected
element is in the bottom-most position. You cannot move the Airports or FEAs/FCAs folders.

Scenario Box  - There is a Scenario box for each scenario labeled Scenario 1, Scenario 2, and
Scenario 3. Each Scenario box groups elements by Airports or FEAs/FCAs.
Click the dropdown arrow next to the scenario tab label to open a menu with two options:

• Copy to  - Copies the list of elements and all parameters in the source scenario to either of the
other two scenarios. If an element already exists in the scenario, the copy function will replace its
parameters in the destination scenario. A warning message reading “One or more elements
already exits. Clicking Continue will replace parameters in the destination scenario” is displayed.
Click Cancel (default) to clear the warning without making any changes.

• Clear Scenario  - Removes all elements from the scenario. A warning message reading
“Parameters of all elements in Scenario [n] will be lost” is displayed. Click Continue to clear the
warning and clear all elements from the scenario. Click Cancel (default) to clear the warning
without making any changes.

Element Right-Click Menu Options  - Right-click an element within a scenario to change the type of
TMI or open IPM Setup. When you change the management option, the new program type is
displayed parenthetically next to the element.
The following right-click menu options are available for airport elements:

• GDP - DAS  - Changes to GDP-DAS program type
• GDP - GAAP  - Changes to GDP-GAAP program type



• GDP - UDP  - Changes to GDP-UDP program type
• Ground Stop  - Changes to Ground Stop program type
• Purge  - Changes to Purge program type
• Impact  - Changes to Impact program type
• IPM Setup…  - Opens the IPM Setup component

The following right-click menu options are available for airspace elements:
• AFP - DAS  - Changes to AFP-DAS program type
• AFP - GAAP  - Changes to AFP-GAAP program type
• AFP - UDP  - Changes to AFP-UDP program type
• Purge  - Changes to Purge program type
• Impact  - Changes to Impact program type
• IPM Setup…  - Opens the IPM Setup component

Hover your mouse cursor over an element within a scenario to display a tooltip containing the
following information: Program Type, Scope, Start Time, End Time, Program Rate, and Pop-Up
Factor. The tooltip is a summary of the information found on the Scenario 1, 2, and 3 tabs.
Scenario Tabs

There are three scenario tabs that represent each scenario on the Scenario Setup tab. The scenario
tab is disabled until the corresponding scenario is created. Once you create a scenario, the
corresponding tab-label parenthetically lists the number of model elements and number of impact
elements in the scenario. Scenario 1 (2/1) indicates that Scenario 1 consists of two Model elements
and one Impact element (see Figure 3-99).

Figure 3-99: Scenario 1 Tab Layout
Changing Segment Order



The tab is divided into segments that represent each element in the order they are displayed on the
Scenario Setup tab. You can drag and drop a segment to change the order displayed on the tab.
Any change will dynamically change the order on the Scenario setup tab and the Multi Graph
component. The displayed order determines the order that the elements are modeled.

Note: Airports are always modeled before FEAs/FCAs; therefore, you cannot move an FEA/FCA
above an airport.

Element ID  action button - Click to open IPM Setup. This button is disabled for Impact elements.
To the right of the Element ID button click the arrow to open the dropdown menu with the following
options:

• IPM Setup…  - Opens IPM Setup for the selected element. Opens with the ADL currently opened
in the Scenario Manager. Note that ADLs are updated only when Reload All  is selected or an
additional element is added to a scenario. If the ADL is behind the current ADL, the Reload All
button will be enabled. IPM Setup is disabled for Impact elements. Only one instance of IPM
Setup can be opened at a time.

You cannot move the IPM Setup component; therefore, in order to return to Scenario Manager, you
must close IPM Setup.

• Copy To  - Copies the specific element and its parameters to all the scenarios or a specific
scenario.

• Move To  - Moves the specific element and its parameters to a specific scenario.
• Load Proposed Parameters  - Select to open a secondary dropdown menu to select from specific

parameter options:
• > Airspace Flow Program  - Loads the proposed AFP parameters. This option is not

available for airports.
• > Ground Delay Program  - Loads the proposed GDP parameters. This option is not

available for FEAs/FCAs.
• > Ground Stop  - Loads the proposed Ground Stop parameters. This option is not available

for FEAs/FCAs.
• Load Actual Parameters  - Opens a secondary dropdown menu to select from specific parameter

options:
• > Airspace Flow Program  - Loads the proposed AFP parameters.This option is not available

for airports.
• > Ground Delay Program  - Loads the proposed GDP parameters. This option is not

available for FEAs/FCAs.
• > Ground Stop  - Loads the proposed Ground Stop parameters. This option is not available

for FEAs/FCAs.
• Open New GDT Mode Instance…  - Opens a new instance of GDT Mode for the selected

element, and copies all parameters to that GDT Mode. This option lets you run a program
without having to re-enter all the information. All current restrictions on the number of GDT
Modes allowed are enforced.

GDT Mode is opened with the ADL currently opened in the Scenario Manager. If the element’s ADL
for the Scenario Manager is later than the current ADL time, the Reload  button in GDT Mode will



be enabled.
This option is disabled for Impact elements.

• Delete Element  - Removes the selected element from the scenario.

Program Type  - Click the dropdown box arrow to select available TMI types for the element:
• GDP - DAS
• GDP - GAAP
• GDP - UDP
• Ground Stop
• Purge - This program type requires no input on any tab option. If Purge is selected, all

selections except Impact/Model and Program Type are disabled.
• AFP - DAS
• AFP - GAAP
• AFP - UDP

Scope  - The scope value is determined by the element’s scope in GDT Mode. If you want to
change the scope, use IPM Setup.

• For a tier-based scope, the dropdown box will contain the available tier keywords for the
selected element.

• For distance-based scope, the dropdown box will contain [x]NM (nautical miles) where ‘x’ is an
editable field. Use the spinners to adjust the scope in 100 nm increments.

Expand or Collapse Segment Arrow
• Click the down arrow toggle button to the left of the Model box to expand the segment. By

default, Impact elements are collapsed and the Expand/Collapse button is disabled as Impact
elements cannot be expanded.

• Click the up arrow toggle button to the left of the Model box to collapse the segment. By
default, Model elements are expanded but you can collapse their presentation.

Model or Impact  - This dropdown box indicates whether the element is a modeled or impact TMI.
Click the arrow to change the element to either Model or Impact. If the FCA is part of a CTOP,
only Impact is available.

Start  - Enter the date and time when the TMI should begin.
End  - Enter the date and time when the TMI should end.
Data Time  - Displays ADL time on which you are modeling and analyzing your TMI. This is a read-
only field in the current FSM version.
Subs  - Indicates whether Subs are on or off. This is a read-only field in the current FSM version.
Program Rate / Pop-Up / Reserve Grid  - This is similar to the GDT Mode Program Rate / Pop-Up
/ Reserve Grid. The primary difference is that you must manually change the PR, Pop-up, and
Reserve values as the Fill between Hours  option is not available. For Fill between Hours
functionality, open the IPM Setup component and make your changes. Any updates will dynamically
change the element’s corresponding segment in the Multi Graph component.



Multi Graph Component
The Multi Graph component has four tabs. Three tabs with stacked bar graphs for each element in
the Scenarios 1,2 and 3, and a tab with consolidated metrics for all scenarios (see Figure 3-100).

Figure 3-100: Multi Graph Component
Multi Graph Menu Bar

The menu bar of the FSM Multi Graph component contains five options: File, View, Bar Graph,
Display, and Help.

1. File Menu
• File > Save As  - Saves the Multi Graph as a .jpg image to a directory you specify.



• File > Print  - Prints the Multi Graph currently displayed on your screen.
• File > Close  - Closes the Multi Graph component.

2. View Menu
The View Menu consists of 15 checkboxes and two additional menu items. Check the box to
view the information and uncheck the box to hide the information.
• View > Rename Window  - Displays the Rename Window dialog box used to change the

component name in the title bar. Enter the desired component name, and click OK to
change the title bar heading. Click Cancel to close the Rename Window dialog box without
making any changes.

• View > Set Tabs Displayed  - Dynamically shows and hides specific coloring schemes for
the Bar Graph component. The selected scheme controls all of the bar graphs.

• View > Current Data  - Replaces GDT Mode’s View > Arrival Data  and View Departure Data
options. The concept of viewing arrival and departure data is not possible in IPM Mode
since you are simultaneously viewing both airspace and airport traffic.

• View > Show Cancellations  - Displays cancelled flights in the color cyan. Cancelled flights
are not automatically displayed in the graph. Showing cancelled flights is useful to compare
the original demand with the demand after the cancellations. To differentiate between
cancelled and regular flights, use the Arrival Status tab to color your flights.

• View > Show Unassigned Slots  - Displays all unassigned slots in the color white for a GDP
or AFP.

• View > Show Legend  - Displays the appropriate color legend associated with the tab option
you are viewing. If you click the legend button on the Bar Graph, FSM dynamically selects
the checkbox for Show Legend.

• View > Time Indicator  - Displays an orange vertical line that remains fixed at the current
time. Like the FSM Time Line, the Bar Graph Component also tracks time.

• View > Cumulative GDP/AFP Indicators  - Displays a brown solid vertical line representing
the cumulative start and end time for a GDP or AFP.

• View > Event GDP/AFP Indicators  - Displays a brown vertical dashed lines to indicate the
start time and end time of a current GDP or AFP. The program time indicators are
displayed automatically when a program goes into effect at the monitored data set. Note: If
the cumulative time and the event time are the same, the solid brown line (cumulative
time) will take precedence over the dashed brown line (event time).

• View > GS Indicators  - Displays a yellow vertical lines to indicate the start time and end
time of a current GS. The GS time indicators are displayed automatically when a GS goes
into effect at the monitored airport.

• View > Model Flow Rates  - Displays a thin colored line that represents the model flow rate
independently of the time-bin convention, enabling you to visualize arrivals and departures
as a dynamic flow rate. The color of the thin line color unique to each scenario. Blue
represents Scenario 1, Magenta represents Scenario 2, and Yellow represents Scenario 3.

• View > ADL AAR Line  - Displays a white horizontal line that runs through the graph
representing the current Airport Arrival Rate (AAR) for the monitored airport or airspace
data set. The ADL AAR (shown by default) is a fixed AAR sent by the FAA Air Traffic
Control System Command Center (ATCSCC) to advise of the number of arriving aircraft a
data set can accommodate at any given interval of time. The AAR changes according to



the interval of time being displayed. For example, an AAR of 60 per hour = AAR of 15
per quarter hour. Only ATCSCC users can change the ADL AAR.

• View > Model Program Rate  - Displays a user-specified Program Rate as a dashed white
line. You use the Model Program Rate for modeling and analysis; you can change this
according to program needs.

• View > Time Increment>15 Minutes, 30Minutes, 60 Minutes  - Displays a bar graph capacity
and demand information based on the time-bin value selected. The default time increment
is 60-minutes. If you click one of the time bin buttons on the Bar Graph, the same
increment displays selected on the associated menu item.

• View > Hours Shown > 2/3/4/5/6/8/10/12/14/16/18/20/22/24/36 Hours  - The default data display
is 10 hours. You can specify the number of hours displayed in the Bar Graph to see more
or less flight data. For example, you may want to view the AAR in 15-minute increments,
which is difficult to see on a graph with 10 hours’ worth of data. To change the number of
hours in the graph, select View > Hours Shown > X Hours (X = number of hours). The
graph automatically updates to show the number of hours specified.

3. Bar Graph Menu
• Bar Graph > Track Time  - Makes the graph move as the time changes. When you track

time in this way, the second bar on the graph is always the current time. When you
uncheck the box, the bars do not move, but you can still use the Time Indicator to
determine the current time on the graph.

4. Display Menu
Display Menu changes the data shown in the Bar Graph to show demand based on the
following display options. Selecting a display option means that the selected display option is
applied across all scenario tab displays.
• Display > ETA / ENTRY  - Displays the Estimated Time of Arrival (ETA) for airport only, and

Estimated Element Entry Time (ENTRY) for airspace only. This is the default display mode.
• Display > BETA / BENTRY  - Displays the Base Estimated Time of Arrival (airport only) and

Based Element Entry Time (airspace only).
• Display > OCTA  - Displays the Original Controlled Time of Arrival.
• Display > CTA  - Displays the Controlled Time of Arrival.

5. Help Menu
• Help > Multi Graph  - Opens the on-line help for the Multi Graph component.

Multi Graph Panel Buttons

The eight buttons in the Multi Graph window are identical to the standard GDT Mode Bar Graph
buttons. The behavior of the panel buttons differs from GDT mode in that any action affects all bar
graphs in all scenarios. For example, if you click the Cancellations toggle button, cancelled flights
are displayed on each bar graph in Scenario 1, Scenario 2, and Scenario 3.

• Save As  - Saves the Multi Graph as a .jpg image in a directory that you specify.
• Print  - Prints the Multi Graph.
• 15, 30, and 60  - Clicking the 15, 30, or 60 time-bin buttons displays each Bar Graph’s capacity

and demand information based on the time-bin value selected. The default time increment is 60-
minutes.



• Legend  - Displays the color legend on each Bar Graph. The same color legend will be applied
to all Bar Graphs on the Multi Graph.

• Model Flow Rate  - Displays the Model Flow Rate line for each Bar Graph.
• Cancellations  - Displays the cancelled flights on each Bar Graph.

Multi Graph Tabs

There are four tabs: Scenario 1, Scenario 2, Scenario 3, and Metrics.
Multi Graph Scenario Tabs

There are three scenario tabs, one for each scenario created on the Scenario Setup tab. There is a
one-on-one correspondence between the number of datasets in a scenario and the number of bar
graphs displayed for each scenario. Once you create a scenario, the corresponding tab label
parenthetically lists the number of models and number of impacts in the scenario. Scenario 1 (2/1)
indicates that the scenario consists of two Model elements and one Impact element (see Figure 3-
101).

Figure 3-101: Number of Multi Graph’s Model/Impact Elements

Below the tabs, the Flow Rate Legend  has a checkbox and color unique to each scenario. The flow
rate option is disabled if the scenario does not have any elements.
The Flow Rate Legend allows you to display the flow rate of an element across the other scenarios.
If an element is in multiple scenarios, the element’s associated flow rate is displayed on the
scenario tab being displayed (see Figure 3-102).
Scenario flow rates are layered from top to bottom using the following precedence: Scenario 1,
Scenario 2, and Scenario 3. For example, if Scenario 1 and Scenario 2 have the same flow rate,
the line would be blue. If Scenario 2 and Scenario 3 had the same flow rate, the line would be
magenta.



Figure 3-102: Multi Graph Flow Rate Legend for Multiple Scenarios
Bar Graph

Each Scenario tab displays a bar graph for each element in the scenario. Impact or Model is
displayed to the right of the element name. The bar graphs are in the same order as they are
displayed in the Scenario Manager. The bar graphs are the standard FSM bar graphs; however,
there some differences to accommodate for the display of multiple bar graphs:

• The horizontal bar at the bottom of the window simultaneously scrolls all elements.
• A single set of Color tabs (View > Set Tabs Displayed) controls all of the bar graphs.
• Only color options with a common legend are enabled.
• The Dynamic Carriers  and Recalculate  buttons found on the Carrier tab in GDT’s Bar Graph has

been removed from the Multi Graph Carrier tab.
Metrics Tab

The Metrics grid contains expandable trees to simultaneously display consolidated statistics across all
scenarios (see Figure 3-103). Use different combinations of the Grouping  and Display  options to
analyze the data.



Figure 3-103: Metrics Tab
Grouping

Four Grouping  options are displayed at the top of the Metrics tab. The selected grouping determines
which statistics are displayed.
If you click Resource, the following statistics are displayed:

• Average Delay
• Maximum Delay
• Total Delay
• Total Flights
• Affected Flights
• Unrecoverable Delay
• % Unrecoverable Delay
• Delay Variance
• Immediate CTs Sent

If you click Arrival  or Carrier, the following statistics are displayed:
• Maximum Delay
• Total Delay
• Total Flights
• Affected Flights

If you click Departure, the following statistics are displayed:



• Average Delay
• Maximum Delay
• Total Delay
• Total Flights
• Affected Flights
• Immediate CTs Sent

Display

Three Display options are displayed below the Grouping section. Not all Display options are available
for all Groupings:

• Number of Elements  (default 5) – Not available for Grouping by Carrier
• Number of Airlines  (default 5) – Not available for Grouping by Arrival, Departure, or Resources)
• Number of CTs  (default 10) – Not available for Grouping by Arrival or Carrier

Use the arrows to select the top number of Elements, Airlines, or CTs to be included in the metrics.
For example, an Airline  value of seven means that the statistics for the top seven airlines will be
displayed for each scenario. All airlines that fall outside of the selected parameters will be grouped
together as “All Others”.

IPM Setup Components
The Integrated Program Modeling (IPM) Setup component allows you to review detailed statistics for
an element’s modeled data. IPM Setup is very similar to GDT Setup. The main distinction is that
you can only model programs in IPM. You cannot run and issue TMIs from IPM Setup. Changes
made while in IPM Setup are reflected in the Scenario tab of the Scenario Manager component.
This section familiarizes you with the IPM Setup components:

• IPM Setup
• IPM Map
• IPM Bar Graph
• IPM Data Graph
• IPM Time Line (Optional)
• IPM Demand by Center (Optional)
• IPM Flight List (see Chapter 6: Viewing Flight Information)

Opening IPM Setup

Unlike GDT Setup, only one instance of IPM Setup can be opened at one time. You must be in
IPM Mode’s Scenario Manager component to open IPM Setup. Use one of the following three
methods to open IPM Setup:

1. On the Scenario Setup tab, right-click an element in a Scenario box, and select IPM Setup...
from the menu options (see Figure 3-104).
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Figure 3-104: Right-click Element in Scenario Box to Open IPM Setup

2. On the Scenario 1, Scenario 2, or Scenario 3 tab, click the Element ID  action button (see
Figure 3-105). This button is disabled for Impact elements.

Figure 3-105: Click Element Action Button to Open IPM Setup

3. On the Scenario 1, Scenario 2, or Scenario 3 tab, click the arrow located to the right of the
Element ID  action button. Select IPM Setup...  from the dropdown menu (see Figure 3-106).



Figure 3-106: Right-click Element Drop-Down Arrow to Open IPM Setup

IPM Setup opens with the ADL currently opened in the Scenario Manager. Note that ADLs are
updated only when Reload All  is selected or when an additional element is added to a scenario. If
the ADL is behind the current ADL, the Reload All  button will be enabled.
You cannot move the IPM Setup component; therefore, in order to return to Scenario Manager, you
must close IPM Setup.
Four default IPM components are opened for the selected data set (see Figure 3-107). The IPM
Setup and IPM Map component are interactive; any change in one is dynamically reflected in the
other component. Other IPM components reflect changes made to the IPM Setup and IPM Map
when you model the TMI.

Note:  All IPM components are labeled IPM in the component title bar. IPM Setup components
also include the Scenario number in the title bar.



Figure 3-107: IPM Setup Default Components

IPM Setup Component Tabs
The IPM Setup window is similar to the GDT Setup window. It consists of a menu bar, seven action
buttons, the Program Type selection box, SUBS Indicator, and three tabs that focus on different
areas of information (see Figure 3-108).



Figure 3-108: IPM Setup Parameters Tab

Select the type of TMI you want to model from the Program Type  selection box:
Airports  have the following Program Types:

1. GDP - DAS - The default Program Type for airports. Not available for FCAs.
2. GDP - GAAP - This program type is similar to GDP-DAS except it automatically sets the

Delay Assignment Mode to GAAP.
3. GDP - UDP - This program type addresses the mix of scheduled and unscheduled (i.e., pop-

ups) demand based on the following parameters: number of reserved pop-ups, target delay



multiplier, and delay limit.
4. Ground Stop - Unlike ground delay programs, which delay flights because of a reduced AAR,

the Ground Stop function prevents flights from departing until further notice. Not available for
FCAs.

5. Purge -  Cancels a GDP or GS, releasing all delay on included flights.
FCAs/FEAs  have the following Program Types:

1. AFP - DAS - Airspace Flow Program available only for airspace data sets. This program is
used to control traffic flow through an FCA.

2. AFP - GAAP - Airspace Flow Program available only for airspace data sets. This program
type automatically sets the Delay Assignment Mode to GAAP.

3. AFP - UDP - Airpspace Flow Program available only for airspace data sets. This program
type addresses the mix of scheduled and unscheduled (i.e., pop-ups) demand based on the
following parameters: number of reserved pop-ups, target delay multiplier, and delay limit.

4. Purge -  Cancels a AFP, releasing all delay on included flights.

Note:    Blanket, Compress Flights, Compress Slots, and Airborne Holding program types are not
available in IPM Setup. FCAs that are included in a CTOP are also not available to model in
IPM Setup.

The IPM Setup component tab options and features change based on the Program Type selection.
The three IPM Setup tabs are Parameters (default selection), Scope, and Modeling Options.
This section discusses the IPM Setup component based on each tab option. Closing the IPM Setup
component closes all the IPM components for the data set. The IPM Setup panel displays the
substitution status the data set: SUBS: ALL ON, ALL OFF

IPM Setup Panel Menu Bar

The menu bar in the IPM Setup component contains three options: File, View, and Help.
1. File Menu

• File > Load Proposed Parameters  -  Opens a secondary dropdown menu to select from
specific parameter options:

- > Airspace Flow Program  - Loads the proposed AFP parameters.
- > Ground Delay Program  -  Loads the proposed GDP parameters.
- > Ground Stop  -  Loads the proposed Ground Stop parameters.
• File > Load Actual Parameters  - Opens a secondary dropdown menu to select from specific

parameter options:
- > Airspace Flow Program  - Loads the actual AFP parameters.
- > Ground Delay Program  -  Loads the actual GDP parameters.
- > Ground Stop  -  Loads the actual Ground Stop parameters.
• File > Open Parameters File  -  Opens the PARAM_DIRECTORY File in file explorer. Select

the parameters file and click Open  to view the Parameters Files.



• File > Save As  - Not available in the current version.
• File > Close  -  Closes the IPM Setup component and all the complimentary IPM components

for that particular element.
2. View Menu

• View > Rename Window  - Displays the Rename Window dialog box and allows you to
change the component name in the title bar.

There are six additional display options under the View  menu. If you close a component and
want to reopen it, use the View  menu options to select and reopen the desired component.
• View > IPM Data Graph  -  Displays the IPM Data Graph component
• View > IPM Map  - Displays the IPM Map component
• View > IPM Bar Graph  -  Displays the IPM Bar Graph component
• View > IPM Time Line  -  Displays the IPM Time Line component
• View > IPM Flight List  - Displays the Flight List for the monitored airport, FEA, or FCA.
• View > Show Demand  - Displays the Demand by Center component.

3. Help Menu
• Help > IPM Setup  - Opens the on-line help for the IPM Setup component.
• Help > IPM Setup Tab  - Select to open the on-line help for the IPM Setup tabs

(Parameters, Scope, and Modeling Options).

IPM Setup Panel Buttons

The seven action buttons are Save  (the button with the disk icon), IPM Map, Multi Graph, Reload
All, Model All, Close, and Reset Parameters. These buttons are active when the feature is available.

• The Save  button is not available in the current version.
• Clicking IPM Map  opens the IPM Map.
• Clicking Multi Graph  opens the Multi Graph component.
• Clicking Reload All  causes FSM to load the latest ADL data into the IPM mode. You then can

model the program using the latest data and make any adjustments you think are necessary.
• Clicking Model All  models and updates your changes in all IPM components for analysis and

review. After you make any modification to any portion of the IPM Setup component, which FSM
indicates by highlighting the tab window area with a red border, the Model All  button becomes
active. After clicking Model All,  your IPM Setup component also resets and the red border no
longer is displayed until you make an additional change.

• Clicking Scenario Mgr  closes all IPM Setup components. It does not close the Scenario Manager
or Multi Graph components.

• Clicking Reset All Parameters  loads the most current ADL, clears any elements of the modeled
data, and returns the IPM settings to their defaults.

Note:    The Run  and Subs OFF  buttons found in GDT Setup are not part of the current
functionality of IPM Setup.

IPM Parameters Tab



The Parameters tab is active for all program types and is the default tab that opens when you open
the IPM Setup component. Within this tab you can specify parameters including the program time,
program rate, and general options for GAAP delay and Purge notifications. Options which are not
features for certain program types are disabled.
You can edit Start  and End  time parameters in the Program Time Options section for all program
types.

• Start -  Enter the date and time when the TMI should begin.
• End -  Enter the date and time when the TMI should end.

The default End time for Ground Stops will adjust to 15 minute increments on the hour (00, 15, 30,
and 45). All other programs will have a default end time on the 14, 29, 44, or 59th minutes. The
End time for Ground Stops will be a time increment that results in at least a one hour GS. For
example, if the Ground Stop Start time is 1902, the default End time will be 2015.
If you are using the slider to select the End time for a Ground Stop, the slider will adjust to 15
minute increments on the hour. Using the slider to adjust the End time for all other programs will
result in an End time on the 14th, 29th, 44th, and 59th minutes. You can populate the times in the
text box to the right of the time field or use the slide bars, which automatically fill the time into the
text box.
The Purge Flights section of the IPM Setup component contains two checkboxes that allow you to
purge flights before a revision start time and after a revision end time as appropriate for AFP/GDP
revisions.

• Before Revision Start  - This checkbox allows you to specify if control times should be purged off
of flights between the revision start time and the cumulative start time. Before Revision Start  is
disabled if a GDP or AFP does not exist for a current data set. The purge Before Revision Start
is enabled only when the selected GDP/AFP start time is later than the existing program’s
Cumulative Start Time. This option is dynamically enabled and disabled with the mouse release
action on the slider bar.

Note:      FSM will reset the Cumulative Start Time to the new (later) start time and determine
which flights are no longer controlled due to the change.

• After Revision End  - This checkbox allows you to specify if control times should be purged off of
the flights between the revision end time and the cumulative end time. After Revision End  is
disabled if a GDP or an AFP does not exist for the current data set. The purge After Revision
End  is enabled when the selected GDP/AFP end time is earlier than the existing program’s
Cumulative End Time. This option is dynamically enabled and disabled with the mouse release
action on the slider bar.

Note:      FSM will reset the Cumulative Start Time to the new  (earlier) end time and determine
which flights are no longer controlled due to the change.

• Compress to Last CTA  - This functionality is available during an AFP (initial and revision), GDP
(initial and revision), and Compression. When checked, all flights that have control times are
eligible for compression. When unchecked, only flights with CTAs through the End time of the
program are compressed.



• Data Time  - This functionality is the ADL time on which you are modeling and analyzing your
TMI. Data Time is a read-only field in the current version of IPM Setup. The default ADL time
always displays in the IPM Setup title bar.

The Program Rate  section is active for all Program Types except Compression, Ground Stop, Blanket,
and Purge. The Program Rate table is oriented horizontally so that the hours are displayed across
the top of the table (see Figure 3-109). The hours shown in the program rate table, range from one
hour prior to the current time to 35 hours ahead of the current time. To view the hours across the
table, use the horizontal scroll bar directly below the table.

Figure 3-109: IPM Setup - Program Rate Section

There are three rates that can be adjusted: the Program Rate, Pop-Up rate, and Reserve rate. Each
rate is represented by a row and is an option in the Fill dropdown menu.
Select a rate type from the Fill  dropdown menu and fill in the associated rates by entering a rate in
the With  box, using the From Hour  and Through Hour  to select the time frame, and clicking Fill.
There are additional features in the Program Rate  section of the Parameters tab that are not included
in the Modify Program Rate  component:

• Load Times  - Click to fill the From Hour  and Through Hour  fields to match the times set in the
Program Time Options section. If you click Fill  after entering the Program Rate and hours, FSM
automatically fills in the appropriate hour columns.

• Pop-up  row - This row is only available for a DAS program. It is disabled and populated with
dashed for all other programs. The Pop-up Factor  accounts for potential “pop-up” flights. For
example, if you change the Program Rate for a certain number of hours to 40 with a Pop-up
Factor of 5, the Program Rate that FSM uses to run the GDP or AFP is 35. This leaves room
for any unknown flights that show up in that hour because the actual capacity of the airport is
40.

• Reserve  slots row - This rate is only available for Unified Delay Programs, that is, GDP-UDP and
AFP-UDP. It is disabled and populated with dashed for all other programs. You can manually
enter values or use existing historical demand predictions found in the Load Historical Pop-Up
window.

• Historical Pop-Ups  - Click to open the Load Historical Pop-Up  window where you can select
specific historical demand predictions which will be used for the TMI. This window is similar to
the view-only window accessed via Utilities > Historical Pop-up Demand  (for more detailed
information, see Chapter 5: Historical Pop-Up Demand). However, you can adjust the values
utilized while still having the predictions visible for reference. High, Medium, and Low  represent
confidence levels for the values as listed in the ADL. Note that predictions fewer than ten per
hour may include a decimal value. Predictions greater than ten per hour are represented by
whole numbers.
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To set the Reserve rate in the IPM Historical Pop-Up window:

1. From the Program Type  dropdown list, select GDP-UDP or AFP-UDP. The Historical Pop-Up
button and the Reserve  row will become enabled.

2. Click Historical Pop-Up. The Load Historical Pop-Up  window opens.
3. Select the High, Medium, or Low  radio button.
4. Click Fill With. The cells in the Load With  row will be populated with the historical values for

the selected confidence level (see Figure 3-110). Note that the Fill With  functionality is not
available for FCAs.

1. Click OK. The window closes and the rates are displayed in the Program Rate’s Reserve  row.

Note:    Even though you used the Fill With  functionality, you can manually edit specific hours in
the Programs Rates  table or the Load Historical Pop-Up  window. Changes made to the Program
Rates  table will be reflected in the Historical Pop-Up  dialog box; likewise, changes made in the
Historical Pop-Up  dialog box will be reflected in the Program Rates  table.

Figure 3-110: Load Historical Pop-Up Window

The menu bar contains two options: File and Help.
1. File

• Print - Prints the Load Historical Pop-Up window as displayed on your screen
• Close - Closes the window

2. Help - Opens online help specific to the Load Historical Pop-Up window
The window contains the following action buttons:

• OK  – Click to save your changes and close the dialog box
• Cancel  – Click to close the dialog box without saving your changes
• Help  – Click to display a pop-up window with a brief description of the component

To set the Pop-Up Factor for a program from the IPM Setup component.

1. Select the Parameters tab on the GDT Setup component.



2. Select Pop-Up Factor  from the Fill  dropdown (see Figure 3-111).

Figure 3-111: Program Rate Pop-Up Factor

3. Enter the number of Pop-Up slots you want FSM to create in With.
4. Enter the hours for this Pop-Up Factor in From Hour  and Through Hour.
5. Click Fill. FSM enters the Pop-Up Factor specified into the appropriate hours (see Figure 3-

112).

Figure 3-112: Pop-Up Factor Filled

6. Select the number in the Pop-Up Factor column. FSM enables the Edit 15  button.
7. Click Edit 15.

The 15 Minute Pop-Up Factor window displays.
8. Enter the Pop-Up Factor you want for each 15 minute increment of the selected hour.
9. Click OK. The edited Pop-Up Factor is highlighted green (see Figure 3-113).

Figure 3-113: Pop-Up Factor Edited in 15 Minutes Increments

You may set the following parameters within the General Options  section of the Parameters tab:

Note:    The fields are available based on the Program Type you select. For more detailed
information, see Chapter 2: Text Fields Display Conventions.

• Delay Limit (Minutes)  - Allows you to set the amount of delay (in minutes) for flights controlled
by a GDP - GAAP. The default Delay Limit  is 180 minutes. If an ADL contains GDP parameters
that include a Delay Limit, that limit displays when you use the Load Parameters feature. Click
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Default  to reset the values to the default times.
• Target Delay (Multiplier)  – This parameter is used to compute pop ups’ additional delay as

compared to other flights. More specifically, it is multiplied by the average delay found in the
DAS Delay Table for the 15-minute time bin in which the flight wants to arrive (ETA).

For example, if flight A is a pop-up and wants to arrive at 1535, the TFMS Core will find the
average delay for known flights in the 1530-1544 time bin and multiply that delay by the Target
Delay (Multiplier). So if the average delay in that 15-minute time bin is 20 minutes and the Target
Delay = 1.5, Flight A’s delay is calculated to be 20 x 1.5 = 30 minutes and will receive a CTA of
1535 + 30 = 1605.
This is not an editable field for DAS or GAAP programs. For DAS programs, the target delay
multiplier is always 1.0 and cannot be edited. For GAAP programs, the target delay multiplier is not
applicable as pop-up flights are assigned to unassigned slots or given the max additional delay.
For UDP programs, the default value is 1.0. Use the arrows to select a new value or type a new
value. As you adjust the number of minutes, the time will increase in the adjacent ddhhmm field.
Valid values are 1.0 to 9.9. Click Default  to return to the default value.

• Earliest R-Slot (Minutes)  - This parameter is used internally within FSM to prevent allocating any
reserved slots that are too close to the current time to be usable. From a system point of view,
the only restriction on the Earliest R-Slot is that it be earlier than the end time of the GDP.

Enter the Earliest R-Slot as a number of minutes that will be added to the TMI Start Time (Event
Start Time). For example, if you think the pop-up traffic for the first 2 hours of your program has
already materialized, you would not want to reserve slots for pop-up flights in those hours. With the
Earliest R-Slot parameter, you can control when you want reserved slots to begin for pop-up flights
by adding 120 minutes to the Program Start.
Zero is the default value. Use the arrows to select a new value or type a new value. Click Default
to reset the values to the default times.

• Adjust Delay (Minutes)  - This parameter is available only when using the Blanket Program Type.
You can use Blanket Adjust Delay  to add or release a specified amount of time from selected
criteria. You should only use Blanket during a GDP. For example, if you had a hole in the traffic
flow, you could select centers, distance, fixes, or aircraft types and enter in a negative number to
release some delay or release all delay by clicking Release. Release  fills in the Adjust Delay text
field with –999, which is equivalent to releasing all delay. Alternatively, you can add delay to the
selected criteria by entering the amount of extra delay in minutes. Click Default  to reset the
values to the default times.

• Purge Notification (Minutes)  - These options are only available when a Purge  program type is
selected. You may change the values for modeling purposes; however, the default values will be
used for the purge. To model the purge using different values, you may either enter the number
of minutes in the fields, or use the spinner controls to change the values in five-minute
increments. These values may not be negative. Click Default  to reset the values to the default
times.

Note:  Changing Purge Notification (Minutes) values is for modeling only. The actual purge uses
the default values.

• AFP Override  - Gives priority to the current AFP over previously issued AFPs. FSM assigns
control times based on the current modeled AFP and overrides any other control times that flights



received due to previous AFPs. These control times do NOT override control times assigned due
to airport based TMIs.

• Slot Hold Override  -  You can change parameters only for RBS++ and Compression. The Slot
Hold Override field allows you to override an airline’s slot holding status by either typing an
airline’s three-letter identifier directly in the text field next to Slot Hold Override  or click Select  to
open the Select Slot Holding window (see Figure 3-62). The Select Slot Holding window lists the
airlines currently holding slots at the data set constraint and allows you to select which airline(s)
to override. Select the box next to each airline to override its slot holding status and include the
slot in compression. When you check a box, that airline’s slot hold status is ignored. Click Clear
to remove entries.

• Exempt AFPs  - To minimize the number of changes to control time for flights that are controlled
by a GDP and to minimize the change in the demand at the AFP, you may exempt AFP flights
from GDP. Selected flights will be treated as previously controlled regardless of their AFP
exemption status and given the first available airport arrival slot after their estimated arrival time,
which is based on their current AFP EDCT and any airline submitted flight delays. FSM will make
an effort not too change the assigned departure time (CTD) for the flight, subject to capacity
constraints at the airport and any known flight delays. Click Clear  to remove entries.

• Exempt  CTOPs  -  To  minimize the  number  of  changes to  control time for  flights that
arecontrolled by a GDP and to  minimize the change  in the demand at theCTOP,  you  may
exempt CTOP  flights  from GDP.  Selected flights  will be treated as previously controlled  regardless
of their CTOP exemption status and  given the  first available airport arrival slot  after their
estimated arrival  time,  which  is  based on their current CTOP EDCT and  any airline submitted
flight delays.  FSMwill  make  an  effort not too change  the assigned  departure time  (CTD) for the
flight,  subject to  capacity constraints at the airport and any known  flight delays.  Click  Clear  to
remove  entries.

You can select parameters for Arrival Fix, Aircraft Type, and Carrier  for all program types except
AFP - DAS, Compress Flights, and Airborne Holding in the Include Only Options section.

• Arrival Fix  - Use the dropdown menu to determine which Arrival Fixes to include in the
operation. You can select ALL (default value) or one individual fix.

• Aircraft Type  - Select ALL (default value), Jet Only, or Prop Only from the Aircraft Types
dropdown menu to specify the aircraft types included in the operation.

• Carrier (Major) -  Select ALL (default value) to include all carriers at that airport. If you want to
include only a single airline, type the carrier’s 3-letter code into the text box. The application
does not allow you to include only one carrier without including its sub-carriers. Likewise, you
cannot include one sub-carrier. Typing a carrier code into this field always includes the major and
its sub-carriers.

IPM Scope Tab

In IPM Setup, the Scope tab is active for all Program Types except Purge. The Scope tab has two
types of exemption criteria for airports, Tier-based and Distance-based. In the Select By  dropdown
box, select either a Tier or Distance based initiative. FCAs can only issue tier-based AFPs;
therefore, distance is not an option.
Scope Tab for Data Sets with Select By Tier Selected

When you select Select By  Tier, the following panel is displayed (see Figure 3-114). The panel
contains four sections where you can modify parameters: Centers - Origin, Airports - Origin, Airports
- Destination, and Flights.



Figure 3-114: IPM Setup - Exempt by Tier Scope Tab

Centers - Origin: You can select the centers you want to include in the program or select a Tier
level from the Scope  dropdown menu:

• Scope: Select a tier option from the dropdown menu. Selecting a Tier, automatically selects the
associated centers. The total number of centers selected displays to the right of the Tier
selection. Click Clear  to erase all centers with checkmarks and return the included tier selection
back to Manual.

• Manual Center Selection:  Click the checkbox to select or deselect individual centers to include in
the program.

Note:  The recommended scope for AFP programs is ALL + Canada

Airports - Origin:  This section of the panel allows you to exempt and non-exempt airports:
• Exempt: You can exempt certain departure airports from a TMI. Enter the three or four-letter

airport code to exempt that airport. Separate airports with a space or a comma. The maximum



number of exempt airports you can enter is 24.
• Non-Exempt: You can include certain departure airports for a TMI that were not originally

included based on the Center section criteria. Select Manual from the dropdown, then enter the
three or four-letter airport code to include that airport. Separate airports with a space or a
comma. The maximum number of non-exempt airports you can enter is 16.

Airports - Destination: This section of the panel is only for airspace datasets and is disabled
for airport data sets.

• Exempt -  You can exempt certain arrival airports from an AFP. Enter the three or four-letter
airport identifier to exempt flights that are arriving from that airport from departure delay. Separate
airports with a space, comma, semi-colon, or colon.

Flights:  This section of the panel allows you to exempt, i.e., give no departure delay, to priority
flights as well as select Exempt by Departure Status  or time.

• Exempt Active Flights Only (By Status):  Selecting this option gives exemption status only to active
flights, therefore, all flights within the scope of the program that are not active are considered
Non-Exempt. This option is selected by default when there is a Ground Stop in place.

• Exempt All Flights Departing Within  ‘XX’ Minutes:  When exempting flights based on departure
time, you may adjust the time either manually by clicking in the field and typing in a value enter
a value, or by using the spinner controls (the up/down arrows to the right of the field) to change
the value in five-minute increments. This value must be greater than or equal to 0. Selecting this
option will exempt all flights with ETDs within XX minutes of the Data Time. This option is
selected by default when there is no Ground Stop in place.

• Exempt Individual Flights:  Enter a flight’s ACID to exempt priority flights.
Scope Tab for Airport Data Sets with Select By Distance Selected

When you select Select By  Distance, the parameters for Distance are displayed. (see Figure 3-115).
The Distance panel contains four sections in which you can modify the parameters: Distance,
Centers - Origin, Airports - Origin, and Flights.



Figure 3-115: IPM Setup - Scope Tab Exempt By Distance

Distance:  When the Distance Panel first displays, the default distance is 199 nautical miles. You
can enter your distance range directly into the Distance text box or click and drag the sliding bar for
the desired distance; this automatically fills in the distance. Remember, anything changed in the
Setup panel is reflected in the IPM Map. You can change the distance range from the Setup panel
and simultaneously view the range ring and what centers/airports are affected on the IPM Map.
Centers - Origin:  You can enter centers to be Exempt  (have higher priority than Non-Exempt) or
Non Exempt.

• Exempt: You can exempt certain centers from a TMI that were originally partially, or entirely,
included based on the Distance criteria. Enter the three or four-letter center identifier to exempt a
particular center. Separate multiple centers with a space or a comma. The maximum number of
exempt centers you can enter is 36.

• Non-Exempt:  You can include certain centers from a TMI that were not included originally based
on the Distance criteria. Enter the three or four-letter center identifier to include a particular
center. Separate multiple centers with a space or a comma. The maximum number of non-exempt
centers you can enter is 16.

Airports - Origin:  This section of the panel allows you to include and/or exempt airports.
• Exempt:  You can exempt certain departure airports from a TMI. Enter the three or four-letter

airport code to exempt that airport. Separate multiple airports with a space or a comma. The
maximum number of exempt airports you can enter is 24.

• Non-Exempt:  You can include certain departure airports from a TMI that were not included
originally based on the Distance criteria. Enter the three or four-letter airport code to include that



airport. Separate multiple airports with a space or a comma. The maximum number of non-
exempt airports you can enter is 16.

• Non-Exempt if Distance:  Use this field to include Canadian airports. If you select a Canadian
airport, FSM includes that airport if it falls within the selected distance parameter.

Flights:  This section of the panel allows you to exempt, i.e., give no delay, to priority flights as well
as select Exempt by Departure Status or Time.

• Exempt Active Flights Only (By Status):  Selecting this option gives exemption status only to active
flights, therefore, all flights within the scope of the program that are not active are considered
Non-Exempt. This option is selected by default when there is a Ground Stop in place.

• Exempt All Flights Departing Within  ‘XX’ Minutes:  When exempting flights based on departure
time, you may adjust the time either manually by clicking in the field and typing in a value enter
a value, or by using the spinner controls (the up/down arrows to the right of the field) to change
the value in five-minute increments. This value must be greater than or equal to 0. Selecting this
option will exempt all flights with ETDs within XX minutes of the Data Time. This option is
selected by default when there is no Ground Stop in place.

• Exempt Individual Flights:  Enter a flight’s ACID to exempt priority flights.
IPM Map: Click this action button to bring the element’s IPM Map to the forefront.

IPM Modeling Options Tab

The Modeling Options tab is available for all program types with the exception of Purge. Once the
parameters are set, you may want to determine which parameters run the best TMI. In this case,
you can take advantage of FSM’s powerful analysis capabilities to view the results of the parameters
you have selected before actually running the operation.
You can use the Modeling Options tab in the IPM Setup component as an analysis tool. There are
four GDP, three AFP, and three GS operations, which analyze the results for any program. You can
select these options from the dropdown menu that displays next to Power Run By  (see Table 3-13).
You use the Power Run function to determine whether you need to modify the parameters. When
any Power Run is generated, FSM automatically saves the Power Run to a file.
To view a scenario, select the type of program to model in the Power Run By  dropdown menu and
click Model All. Model displays the effects of potential operation parameters and how traffic at the
airport would be affected by using these parameters for an actual program in all IPM components.
Review the program statistics in the Data Graph. To preview the effects of running a Power Run
scenario as an actual program, move the black line on the Data Graph component to other options
displayed on the X-axis. This is discussed in more detail in the Data Graph Component Section.
With the exception of Power Run for Decision Time, you can preview the proposed parameters and
their effect on the airport’s traffic.

Note:  After you click Model All, the Setup Panel no longer has a red border, indicating that all
the components reflect the information in the IPM Setup component.

IPM Power Run Options

The different options when using Power Run By  describe what data is displayed on the X-axis of the
Data Graph and the headers in the Data Table. The Program Type you select determines which
options are displayed in the Power Run By dropdown menu. All GDP functions have “GDP” listed



before the Power Run Type, all AFP functions have “AFP” listed before the Power Run Type, and
all GS functions have “GS” listed before the Power Run Type.

Table 3-13:   (Continued)Power Run Options by
Program Type

Program Type Power Run By Options

GDP - DAS

GDP Distance/Center Group
GDP Data Time
GDP Distance/Center Group &
Data Time

GDP - GAAP

GDP Distance/Center Group
GDP Data Time
GDP Distance/Center Group &
Data Time

GDP - UDP

GDP Distance/Center Group
G P Data Time
GDP Distance/Center Group &
Data Time

AFP - DAS AFP Percent Demand
AFP Percent Capacity
AFP Data Time

AFP - GAAP AFP Percent Demand
AFP Percent Capacity
AFP Data Time

AFP - UDP AFP Percent Demand
AFP Percent Capacity
AFP Data Time

Ground Stop GS Center Group
GS Time Period
GS Center Group & Time Period



Figure 3-116: IPM Setup - Modeling Options Tab

Note:  Distance variables are only editable when you model a Distance based Program.

IPM Program Cancellation Time

Using the Program Cancellation Time, you can model unrecoverable delay assuming a program
cancellation time other than the program start time. The field defaults to the program start time and
uses the ddhhmm format. The Program Cancellation Time  is available for all Power Runs for GDP
and AFP program types, but not for the GS program types. The Program Cancellation Time  defaults
to the Program's Start time in the IPM Setup panel. If you change the Start Time, it is dynamically
reflected in the Program Cancellation Time.
A checkbox labeled Freeze Cancellation Time  displays to the right of the Program Cancellation Time.
By default the checkbox is unchecked. When checked, the Program Cancellation Time  does not
change with a newly entered Start Time  or when FSM reloads a new ADL.
GDP Power Run Options

• GDP Center Group: This option allows you to view the effect of the “proposed parameters” on
the different center groups. The post-operation demand rate for each hour for a specific group of
centers displays in the Data Graph. Other information displayed, includes average delay, number
of affected flights, and total delay.

• GDP Data Time: Select GDP Data Time  in the Power Run By  dropdown menu. This option is
available only for GDP program types. This option allows you to view the effects of the proposed
GDP according to the time the GDP is issued. Using the display, you can determine how far in
advance you need to issue the GDP. Any hour whose demand still exceeds the AAR is
highlighted in red.

• GDP Distance: Select GDP Distance  from the Power Run By  dropdown menu when modeling
either a GDP or GS. This function shows you the effect of running a GDP or GS for various
distance parameters. When GDP Distance is selected from the Power Run By  dropdown menu,
three text fields become active in the Modeling Options tab: Start Distance, End Distance, and Step
Size  (distance increment). The default is set to start at 199 nautical miles and end at 2600
nautical miles with a step size of 200 nautical miles. You can manually enter your desired



distance and increment range into the appropriate text fields.
• GDP Center Group & Data Time: Select GDP Center Group & Data Time  from the Power Run

By  dropdown menu. This option is available only for GDP program types. This function combines
Power Run by Center Group and Power Run by Data Time. When you perform Power Run by
Center Group & Data Time, you can view all available options to run a GDP using a particular
center group at various data times.

• GDP Data Time & Distance: Select GDP Data Time & Distance  from the Power Run By
dropdown menu. This option is available only for GDP program types. This function combines
Power Run by Data Time and Power Run by Distance. When you perform Power Run by Center
Group & Data Time, you can view all available options to run a GDP using a particular distance
at various data times. Just as in the Distance set up, three text fields become active in the
Modeling Options tab: Start Distance, End Distance, and Step Size  (distance increment). The default
is set to start at 199 nautical miles and end at 2600 nautical miles with a step size of 200
nautical miles. You can manually enter your desired distance and increment range into the
appropriate text fields.

AFP Power Run Options

• AFP Data Time: This option allows you to view the effects of the modeled AFP according to the
time the AFP is issued. Using the display, you can determine how far in advance you need to
issue the AFP.

• AFP Percent Demand: This is the default option when you select an AFP RBS program type.
An AFP Percent Demand Power Run has three fields: Min Percent Demand (%), Max Percent
Demand (%), and Step Size. The default is set to start at Min Percent Demand of 50% and Max
Percent Demand at 100% with a Step size of 10%. You can change the min and max percent
demand and increment range to meet your needs. The AFP Percent Demand Power Run
scenario analyzes alternatives by increasing/decreasing average demand for the indicated AFP
start/end time. Moving the black vertical line in the Data Graph to adjust the percent of demand
automatically adjusts the AFP AAR to meet the adjusted demand.

• AFP Percent Capacity: This Power Run analyzes alternatives by increasing or decreasing the
modeled AAR value for the indicated AFP Start and End times. An AFP Percent Capacity Power
Run has three fields: Min Capacity Reduction (%), Max Capacity Reduction (%), and Step Size. The
default value for Min Percent Capacity is 50. The default for Max Percent Capacity is 100. The
Step Size default is 10.

Ground Stop Power Run Options

• GS Center Group: This Power run allows you to see different statistics for all center groups. The
Data Graph’s X-axis and the Data Table’s column header display the various center groups. This
option is available only for GS program types.

• GS Time Period:  Select GS Time Period  from the Power Run By  dropdown menu. This option is
available only for GS program types. This function shows you the effect of running a ground stop
for various lengths of time. When you select GS Time Period, two text fields become active:
Number of Start Times  and Number of End Times. The default for both is set to 2, but you can
manually enter in another value to meet your analysis needs

Note:  If you decide to run a GS for longer than one hour, FSM provides a warning message
to ensure you want the ground stop to last for that duration.

• GS Center Group & Time Period: This Power Run allows you to see which combination of



center groups and time periods put in the GS parameters would produce the best program. The
Data Graph’s X-axis and the Data Table’s column headers show the various Time Periods and
Center Group combinations. This option is available only for GS program types.

IPM Map Component
The IPM Map component is the same as the GDT Map component. Selections made in the IPM
Setup component are reflected dynamically in the IPM Map component. Airports that the server is
currently monitoring are displayed with the airports’ three-letter identifier and a colored dot indicating
the GDT status of each airport. FCAs that the server is currently monitoring are displayed with a
colored boundary that indicates the AFP status of that FCA. The title bar displays the normal
component labeling conventions. IPM is displayed in the title bar to indicate that you are looking at
the Map in IPM mode. Adaptive compression status displays in the SUBS section.
The IPM Map component allows you to design a TMI visually by selecting/deselecting airports and/or
centers. Selecting/Deselecting airports, centers, and adjusting the distance range interactively updates
other IPM components.
IPM Map Zoom Capabilities

IPM Map contains the same zoom capabilities as the Map in Live mode, for more detail refer to
Map Component section of this chapter.
Distance Based GDPs

When you select a distance based GDP in the IPM Setup component, a maroon colored “range
ring” displays on the IPM Map component. The default distance is set to 199 nautical miles. The
range distance is indicated on the IPM Map just outside the top of the ring. In addition to adjusting
the range from the IPM Setup component, you can alter the distance directly from the IPM Map. Put
your cursor on the edge of the distance ring until the cursor turns into direction arrows, then hold
down the left mouse button and drag and drop the edge of the ring to increase or decrease the
distance.
All airports within the range limit are included automatically into the program and colored red. To
exclude an airport from within the distance range, just click the dot for that particular airport. Clicking
an airport within the distance ring turns the dot to green and excludes that airport from program
delay.
Any additional airports you select are displayed in the IPM Setup component in the Airports: Non
Exempt or Exempt field  in the Scope tab. Likewise you can select/deselect centers to include in a
program from the IPM Map. Clicking once on a center includes the center in the program. The color
of the selected center changes to maroon and the airports within that center change color indicating
that the program includes them as well. The selected center displays in the IPM Setup component in
the Centers: Non Exempt  field in the Scope tab. Clicking only once on a center that is already
included within the program selection does not reflect any visual difference on the screen.

Table 3-14: (Continued)Mouse Actions on the IPM Map

Mouse Action Description

Click Airport Toggle an airport from Exempt/Non-
exempt

Click center once Includes Center in program
Click center twice Exempts center from program delay
Click center three
times Default selection by distance



Tier-Based GDPs

The initial default setting when you open IPM Mode components is an internal tier-based GDP.
When you select a tier based GDP from the GDP Setup component, FSM colors all centers included
in a TMI maroon on the map and colors all airports included red. For example, the next figure
illustrates a SFO 1st  Tier GDP with user selected airport, PHX, as an additional Non-Exempt airport
(see Figure 3-117). The method of selecting/deselecting airports and/or centers is the same as
described above in the distance based GDP.

Figure 3-117: SFO 1st Tier Program

The following IPM setup component corresponds with the IPM Map component (see Figure 3-118).



Figure 3-118: IPM Setup Component ORD 1st Tier
IPM Map Menu Bar

The IPM Map component menu bar contains four options: File, View, Map, and Help. The menu
selections are the same for the IPM Map as they are for the Monitor Live Map—see the Map
Component section in this chapter for more information. The Auto-Show menu on the IPM Map is
disabled for all data set types.

IPM Bar Graph Component
The IPM Bar Graph component is one of the default components opened in IPM Setup. The Bar
Graph allows you to view arrival demand at the airport or FCA being monitored and compares
actual data with proposed parameters. By default, the IPM Bar Graph displays flights based on their
ETAs for modeled Airport TMIs or ENTRY times for modeled Airspace TMIs.
Click Model All  on the IPM Setup component to view the modeled parameter results in the Bar
Graph as well as the Data Graph component. The IPM Bar Graph menu and tab options are almost
identical to the GDT Bar Graph. Please review the Bar Graph Component section above for more
detail.
Like the GDT Bar Graph, the IPM Bar Graph displays both solid and hashed bars. Solid bars
represent the original data, while hashed bars represent modeled data (see Figure 3-74).



Figure 3-119: IPM Bar Graph
Model and Impact Element Buttons

In GDT mode Model and Impact Element buttons are displayed on the GDT Bar Graph. These
buttons do not exist on the IPM Bar Graph. Open the Multi Graph component to view the model
and impact IPM Bar Graphs.

IPM Data Graph Component
The IPM Data Graph component opens in front of the IPM Map when you click Reload All  or Model
All  from the IPM Setup component. You have the option to review, or model your ground delay
parameters before actually running the program or revising any parameters. Click Model All  on the
IPM Setup component to view the initiative’s results with your current parameters in the Data Graph.
From the Modeling Options tab on the IPM Setup component, you can choose the type of data you
want to view on the Data Graph’s X-axis. When you click Model All, you can view the results of
various scenarios. You have the option to change your parameters, and analyze the program further.
Selecting Different Scenarios

You can view all the available scenarios based on the Power Run selection from the IPM Setup
component. For example, selecting Power Run By > GDP Center Group  from the Modeling Options
tab on the IPM Setup and then clicking Model All,  displays all the available tiers for the monitored
airport on the Data Graph component’s X-axis. Your modeled scenario statistics are displayed in the
Legend Table. Use your cursor to drag the black vertical line to a center group, or just move the
cursor over the desired center group and click to move the line. The delay statistics to the right of
the Data Graph reflect the line of scenario delineation. In addition, changing the center option
automatically updates all IPM components to reflect the new parameters. The Data Graph component
includes a roll-over feature. Rolling your cursor over any line in the Data Graph gives you the delay
statistics for the colored line that reflects the results of the center group. From the Data Graph, it is
easy to visualize what center groups give the best results.
Delay Statistics



The Legend Table displays the delay statistics. By default the Legend Table displays when you open
the Data Graph component. You can hide the legend by un-checking the View > Show Legend  box
from the Data Graph Menu. In the Legend Table, you can view a desired delay statistic several
ways. Selecting the All  checkbox selects and displays all the delay statistics. Selecting the Default
checkbox displays the default delay statistics, which are Max Delay, Avg Delay, Max Air Hold, Avg
Air Hold, and Delay Var. You can select/deselect any of the delay statistic checkboxes that you want
to view in the Data Graph. To view one delay statistic in more detail, select the desired radio button
option, located to the left of the checkboxes. The radio button option displays only one delay statistic
at a time, but gives a more refined looked at the numbers. The Data Graph includes the following
Delay Statistics:

• Total # Flts: The total number of flights included in the TMI (cancelled and exempt flights) for
each particular power run scenario. Default color is pink.

• Affected Flts: The total number of flights included in and affected by the TMI for each particular
power run scenario (non-exempt and non-cancelled flights only).

• Total Delay: The total amount of delay that would occur if you ran that particular scenario.
Default color is maroon.

• Max Delay: The maximum amount of delay (in minutes) that any one flight would receive if you
ran that particular scenario. Default color is white.

• Avg Delay: The average amount of delay (in minutes) flights would receive if you ran that
particular scenario. Default color is black.

• Max Air Hold: The maximum amount of airborne holding delay (in minutes) that would be placed
on any one flight if you ran that particular scenario. Default color is lavender.

• Avg Air Hold: The average amount of airborne holding (in minutes) that would be placed on
flights if you ran that particular scenario. Default color is orange.

• Stack: The amount of flights that would be left in the “stack” hour following the end of the
initiative if you ran that particular scenario. Default color is hunter green.

• Unrec Delay: Unrecoverable delay is the amount of delay that remains on flights even if you
release the TMI right before the start time for the selected scenario. FSM determines this value
by setting the time to the TMI start time and performing the release delay function. Default color
is lime green.

• % Unrec: Percentage of Unrecoverable delay is a value that FSM calculates by taking the
Unrecoverable Delay and dividing it by Total Delay (Unrecoverable Delay/Total Delay). This is the
percentage of delay that remains even if you release all delay at the start time for the selected
scenario. Default color is yellow.

• Delay Var: Delay Variability is the standard deviation of the carriers’ average delay. FSM
determines this value by taking the average delay of all carriers to see if they are similar. If the
average delay is similar for all carriers, the delay variability is a small value. Larger deviation, or
increased dissimilarity of average delay for all carriers, results in larger delay variability values.
Default color is red.

• EMA: The Equity Metric for Airlines (EMA) is a metric that indicates (as a whole) how equitable,
or fair, the proposed initiative is for the airlines. Equity is determined by comparing the delay
assigned in a proposed initiative to that which results if you use the airborne holding model. You
must view any deviation from the airborne holding model as decreased equity. The values shown
in this field are integers rounded from the calculated values. A value of 1 indicates that the
initiative option results in delays that are exactly the same as those for airborne holding. A value
from 2 to 8 indicates an option that still exhibits good equity, though the one with the lower
value is still preferred. A value from 9 to 16 indicates an option with increasingly significant
deviation from the standard. A value above 16 indicates an option with poor equity. Default color



is cyan.
• EMF:  The Equity Metric for Flights is a metric that indicates (as a whole) how equitable, or fair,

the proposed initiative is for all the flights. Equity is determined by comparing the delay assigned
in a proposed initiative to that which results from using the airborne holding model. You must
view any deviation from the airborne holding model as decreasing equity. The values shown in
this field are integers rounded from the calculated values. A value of 1 indicates that the initiative
option results in delays that are exactly the same as those for airborne holding. A value from 2
to 8 indicates an option that still exhibits good equity, though the one with the lower value is still
preferred. A value from 9 to 16 indicates an option with increasingly significant deviation from the
standard. A value above 16 indicates an option with poor equity. Default color is blue.

• Avg Dly Diff: The difference in the calculated average delay prior to and after the program. This
is always a negative number and FSM only calculates it for a Compression program.

IPM Data Graph Menu
The menu bar in the IPM Data Graph  component contains three options: File, View, and Help.

1. File Menu
• File > Save As  -  Saves the Data Graph as a.jpg image in a directory that you specify.
• File > Print  -  Prints the Data Graph that is currently active on your screen.
• File > Close  -  Closes the Data Graph component only.

2. View Menu
• View > Show Legend  - By default the checkbox is selected and the color legend of the

delay statistics is displayed. Deselect the checkbox to hide the legend and the delay
statistics.

3. Help Menu
• Help > Data Graph  - Opens the on-line help system.

IPM Demand By Center Component
The IPM Demand by Center component provides you with an additional analysis tool to help with
scope decision making for GDPs, AFPs, and Ground Stops. The Demand by Center component
functionality is similar to that of the Data Graph, in that there is only data available for display after
you model a TMI. After you model a TMI, from the Scope tab of the IPM Setup component, click
Show Demand  or from the IPM Setup component, select View > Show Demand.
The Demand by Center component displays the scope of the modeled TMI and has three columns:
Centers, Non-Exempt, and Exempt. All centers and the top five airports within each center (based
and ordered primarily by the number of Non-Exempt flights and then by the number of Exempt
flights) are displayed under the Centers column. The number of Non-Exempt flights displays under
the Non-Exempt column and the number of Exempt flights for each center or airport displays under
the Exempt column.
A red dot to the left of the center or airport identifier indicates that at least one Non-Exempt flight is
present within that center or airport. A green dot indicates that all flights are Exempt within that
center or airport (see Figure 3-120).



Figure 3-120: Demand By Center

By default, the Centers are collapsed. Click the key icon next to the center identifier to expand the
center and view the top five airports within each Center. If there are more than five airports with
included flights in the selected Center an additional “Others” row combines the rest of the flights
within the remaining airports. If a center does not contain any flights, that center’s airport list is
empty.
Demand By Center Menu Bar

The Demand By Center menu bar contains two options, File  and Help.
1. File Menu

• File > Save as  - Saves the Demand By Center window as a .jpg image in a directory that
you specify.

• File > Print  - Prints the Demand By Center component that is currently active on your
screen.

• File > Close  - Closes the Demand By Center component only.
2. Help Menu

• Help > Center Demand  - Opens the on-line help for the Demand By Center component.

IPM Time Line Component
The IPM Time Line component is an optional component in IPM Mode. To open the IPM Time line,
select View > IPM Time Line  from the IPM Setup component menu bar.
The IPM Time Line Component is the same as the GDT Time Line Component with the exception
that the title bar contains IPM and includes the Scenario number (see Figure 3-121).



Figure 3-121: IPM Time Line Title Bar
IPM Time Line Menu Bar

The menu bar in the IPM Time Line component contains five options: File, View, Time Line,
Display  and Help.

1. File Menu
• File > Save as  - Saves the IPM Time Line as a .jpg image in a directory that you specify.
• File > Print  - Prints the IPM Time Line component that is currently active on your screen.
• File > Close  - Closes the IPM Time Line component only.

2. View Menu
• View > Rename Window  - Displays the Rename Window dialog box and allows you to

change the component name in the title bar. Enter the desired name then click OK  to
change the title bar heading. Click Cancel  to close the Rename Window dialog box without
making any changes.

There are ten additional display options under the View menu. For items with checkboxes,
select the checkbox to view the information.
• View > Set Tabs Displayed  - You can dynamically show and hide specific coloring schemes

for the Time Line component.
• View > Arrival Data  -  Displays all arrival data for that data set.
• View > Departure Data  -  Displays all departure data for that airport.
• View > Show CNX/DO  - Displays all cancelled and drop out flights under the column

marked CNX, to the right of the active flight information.
• View > Show Legend  - Displays the appropriate color legend associated with the current

view. If you click the legend button on the Time Line, FSM dynamically selects the
checkbox for Show Legend.

• View > Open Slots in Carrier Color  - Displays all open slots due to cancelled or delayed
flights in the associated carriers color.

• View > Show Unassigned Slots  - Displays all unassigned slots during a GAAP GDP or
AFP.

• View > Auto Icons  - Displays flights in the TSD icon format. This is the default Time Line
view. The TSD format displays different icons based on the flight aircraft weight. When you
select Auto Icons, the same icon is used to represent all aircraft weights).

Table 3-15: (Continued)Auto Icons



Auto
Icon

Enabled

Auto Icon
Disabled Description

Jumbo

Jet

Heavy

Prop (Includes Turbo and
Piston)

• View > Flight Info  - Displays the Flight Info window for a quick reference on the flight.
• View > Flight Detail  - Displays the Flight Detail window for more in-depth information on the

flight.
• View > Flight List  - Displays the FSM Flight List. 

Note:  View > Arrival Data, Show CNX/DO, Open Slots in Carrier Color, Show Unassigned Slots,
and Auto Icons  checkboxes are selected by default.

3. Time Line Menu
• Time Line > Track Time  - Allows you to turn Track Time on and off. To force the Time

Line component to update when the current hour changes, select Track Time. When the
hour changes, the Time Line moves forward one hour. If you uncheck the Track Time box,
you can scroll forward or back in time and at the next update time the Time Line does
not return to the current time.

• Time Line > Set Time  - This option is enabled only under Historical Data Mode and allows
you to choose the time to view within a set of historical data.

• Time Line > Search By Callsign  -  Allows you to find a particular flight by entering the
flight’s callsign and origin airport. The flight icon in the Time Line is highlighted with a
white box.

Figure 3-122: Search By Call Sign

4. Display Menu



• Display > ETA  - Display flights based on their Estimated Time of Arrival (ETA).
• Display > BETA  - Displays flights based on their Base Estimated Time of Arrival (BETA).

The BETA matches the ETA and is frozen when the flight becomes active or when the
flight becomes controlled.

• Display > IGTA - taxi  - Displays flights based on their Initial Gate Time of Arrival (IGTA)
minus taxi time (IGTA Wheel Time). The IGTA is based on the OAG times or flight plan
times and never changes. Taxi time default is 10 minutes, but you can change it in the
IPM Control window.

• Display > OCTA  - Displays flights based on their Original Controlled Times of Arrival
(OCTA), Original ETA, OGTA Wheel Time, or ETA position, depending on the available
information. For example, if the Original CTA is not available, FSM uses Original ETA and
so on. This time never changes.

• Display > EAFT  - Displays flights based on their Estimated Arrival Fix Time (EAFT), which
is the time at which the flight crosses its designated arrival fix.

• Display > CTA  - Displays flights based on their current Controlled Time of Arrival (CTA).
• Display > ENTRY  - Displays flights based on their current Estimated Element Entry Time

(Airspace data set only)
• Display > BENTRY  - Displays flights based on their current Based Element Entry Time

(Airspace data set only)
• Display > OENTRY  - Displays flights based on their current Original Element Entry Time

(Airspace data set only)
5. Help Menu

• Help > Time Line  -  Opens the on-line help for the IPM Time Line component.
• Help > Legend  -  Opens the on-line help for the Time Line icon legend.

IPM Flight List Component
The IPM Flight List component is an optional component in IPM Mode that allows you to view the
modeled results for multiple flights. To open the IPM Flight List, select View > Flight List  from the
IPM Setup component.
The IPM Flight List component is the same as the GDT Flight List component with the exception
that the title bar contains IPM and includes the Scenario number.



Figure 3-123: IPM Flight List View

For more information on the Flight List component, see Chapter 6: Viewing Flight Information.
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